Custom Hotspot indicators not showing in PixRiot

kiwirotate

New member
Hi , I have been using pixriot to host the files to show a 360 with multiple hotspots embedded via iframe on a squarespace page. All good so far. But I have just created a custom hotspot indicator and saved as png outside of the webrotate folder. (Windows give a permission error when trying to save to the c drive prog files x32 folder). I was able to add it and select it in spoteditor and locally it looks fine when previewd. When I upload the published 360_assets to pixriot the custom indicator does not show. I have changed one of the hotspots to be an included standard indicator and this works OK but just this single hotspot.

I can always revert to a standard indicator but would like to use the custom colour version I have created. How can I do this with pixriot? Thanks.
 

WebSupport

Active member
Hi, good news! We do have initial support for custom indicators in PixRiot. Please follow these steps:

1) Create some folder in PixRiot and upload your custom hotspots indicator icons there (drag and drop them there). Note that once everything is configured as per the following bullets, PixRiot viewer will look for all hotspot indicators in this folder, e.g if you use the default ones, they would also have to be uploaded in this folder.

2) Click View button on one of the icons you have uploaded so it opens in a separate browser tab.

3) Copy the icon URL from the address bar and remove the icon file name so the URL ends with your folder name and paste it in the WebRotate 360 Configuration's Graphics Path field as per attached screenshot.

4) Refresh your browser cache. Sometimes you may need to wait a minute or two for the change to propagate to various servers around the world.

pixriot-360-product-view-custom-hotspots.jpg
 

kiwirotate

New member
Thanks, this worked. It seemed like I needed to republish the 360 files after uploading the hotspot files but it is working. Might be worth adding a pop up when you choose to Add... a new hotspot to alert Pixriot users to this method. Thanks.
 

WebSupport

Active member
Thanks for confirming :) True, we need to give users heads up on how to use custom hotspot indicators as it's different with various CMS plugins we have as well.
 

WebSupport

Active member
With the latest update we made it very easy to get a URL of a PixRiot folder with hotspot indicator icons. So instead of going through the step #2, just click the globe button in your folder item and copy the URL you will see there and paste it in the Graphics Path as per step #3 above.
 

WebSupport

Active member
Here's updated steps in the latest PixRiot release:

1. Create some folder in PixRiot where you will store your hotspot indicator images.

2. Click "globe" icon next to the new folder.

3. Select Path tab at the top of the form and then COPY the folder path.

4. Got to Settings menu on the left, then Configuration -> WebRotate 360 -> Edit and paste the folder path under Graphics Path and save.

5. Go back to the new folder, expand it and upload any custom and/or default hotspot indicator images your 360 product spins require under that folder, e.g. via drag & drop.
 
Top