Label Action: Play to selected label


New member
Hey there,

I am currently working on implementing an animation with two buttons:
1) The button "open" should play the animation to the Last Frame #72,
2) The button "close" should play the animation back to the First Frame #1.

I have configured both buttons as fixed hotspots, each with Label Action to Play the animation to the right frame - see screenshots.

However, once I click the buttons, the animation seems to skip all frames in-between and jumps directly from frame #1 to #72, and vice-versa. I have tried different combinations of Direction settings under Control (e.g. "Do not loop rotation" enabled), but it didn't help me get both buttons playing the animation back-and-reverse as I defined above.

But if I choose Label Action to Play e.g. to #10, then the animation works fine. It seems to me that the setting "Do not loop rotation" does not apply when using "Label action: Play to selected label."

Is there are workaround to make this work before reverting to the API?



  • Bild1.png
    140.1 KB · Views: 595


Active member

Yes, until recently the only option for the "play to label" animation was to animate via the "shortest" path. I.e by default it calculates the fastest route to the label and animates accordingly. Recently we added more granular control which should help with your issue. Please see attached screenshot:


Will send you the latest v3.6.5 beta build with this enhancement via email as this was not publicly released yet :cool:


New member
Thank you. I have now tested your new beta pre-release. It is amazing and so flexible with the Play-to-Label options.

Do I also need to update the WordPress plugin too to make it work on the website? The animation works well in the local browser, but it still follows the "shortest-path" once on the WordPress server.



Active member
Oh... we can send you updated WordPress plugin with this feature on Monday-Tuesday.

Alternatively, you can copy the contents of the imagerotator folder that you can find in your published SpotEditor output (using the new update) over the contents of the same folder located in the webrotate plugin folder under wp-content/plugins in your WordPress installation. You may backup the original imagerotator folder just in case.

Just let me know if you rather prefer to wait for the plugin update next week.


New member
Hi, I have copied the imagerotator folder - and now it works perfectly. No need to send the plugin.
Thank you for such a fast response and a quick solution.