Transparent Background not taken into account ?

Thomas C

New member
Hey guys,

I just discovered your softwares and tools, thanks this is great material.

I am only having trouble with the transparent background of my images once gone through spot editor. I followed all the possible options explained through your website but still can't get the result I am looking for, for my proto.

In this sense I have done the following :

Uploaded PNG transparent files
Chose transparent in the interface/style section of the editor
Changed the CSS (erase background / background:#fff;) of the style I am using in the Xml file of your pluggin (downloaded and uploaded on my server)
Changed the CSS (erase background / background:#fff;)) of the style I am using in the Xml file of my 360 project on my computer

Trying this shortcode as said in another topic : [wr360embed name="view2" width="100%" background="rgba(0,0,0,0)" config="url-of-the-viewer-config.xml"]

... as you can guess, none of this worked and it seems that I have a white background around my spin picture (like if the transparent background of my PNG files had not been taken into account by the Spot Editor, + a grey background circling it. I think it is what you call the viewer background.

I would be glad to get some help from one of you guys ..

Thanks in advance ;)



Active member
Ho Thomas, and thanks for contacting us here! We did receive your email and voicemail as well :)

Do you mind sharing a link to your WordPress page with the shortcode?

Thomas C

New member

Sorry for the late reply, I didn't though you'd be that reactive. Thanks for the answer, sorry if the multiple contacting ways bothered you, I didn't really know how to get to the right service.

After digging a little, I think that the white backgrounds appears on the pictures once they are treated by spotEditor (surely I missed a setting or something), because I ad them as Transparent PNG24 (I tried with normal PNG) and the result as PNG but with a white background.

Here is the link to the Wordpress page : [link removed]

On this page, you will first find the 360view above a picture background (can't see it because of the white background and grey frames > "Viewer Background"?) + my initial picture and the same picture taken from the folder created with the publishing/saving process of SpotEditor.

Thank you for your support,

I remain at your disposal should you need any other information,

Best Regards,
Thomas Cotel


Active member
Somehow we missed your reply! Sorry... :oops: I believe you just need to select this option in the attached screenshot in SpotEditor:


Does this help?


New member
Hi! I'm following the instructions shown here but I can't make my 360 view transparent. This is the link where I'm testing my asset:


Active member
Hi there! It looks like you are using our WordPress plugin. In the plugin we have support for configurable background color and the default is white which is what you see.

Please go to the webrotate settings in admin and enter 'transparent' in the Viewer background field (not quotes). It should work like intended then I think.

PS: with narrow products like this, we usually suggest to crop as much blank space on left and right as possible with some minor padding as per this video tip: